Probleme mit Garmin und Strava

Garmin ist im Bereich der Navigation wohl recht bekannt und es gibt es eine große Anzahl an Geräten die die Aufzeichnung verschiedener Aktivitäten ermöglichen. Die Aktivitäten kann man dann zum Beispiel zu Strava hochladen. Bei manchen Geräten (z.B. die Edge-Reihe) kann man die Aktivitäten autom. zu Garmins eigenem Fitnessportal „Garmin Connect“ hochladen und dieses wiederum autom. Mit Strava synchronisieren. Wenn alles funktioniert, ist das nach einmaliger Einrichtung (Connect mit Strava verbinden) ganz einfach. Leider habe ich derzeit ein Problem mit Garmin und Strava.

Zumindest scheint es (mal wieder) mich erwischt zu haben. Andere Jute Jungs wie Björn B. oder Lars haben wohl keine Probleme.

Mein Garmin-Gerät habe ich erst vor wenigen Wochen gekauft, ich hatte aber schon 2 Fälle, in denen es Probleme gab. Der Upload zu Connect war problemlos – aber die Touren tauchten bei Strava nicht auf. Ich habe versucht, die Dateien von Connect runterzuladen (als gpx und tcx) um sie manuell bei Strava hochzuladen. Dabei meldete Strava aber immer Fehler („Improperly formatted data“). Nachdem das Problem ein erstes Mal auftrat, unternahm ich wieder ein paar Touren, bei denen alles problemlos lief. Als das gleiche Problem wieder auftrat, habe ich die von Connect exportierte Datei an den Support von Strava geschickt. Eine Antwort bekam ich schon am nächsten Tag: Es handele sich um einen „future time error“. Den habe man behoben und die Daten schon für mich bei Strava hochgeladen

Auf Nachfrage bekam ich noch folgenden Screenshot, der aufzeigt, wo das Problem genau liegt. Der erste Zeitstempel, wo die Tour gestartet wird, ist noch korrekt. Dann hat Garmin aber bei jedem Trackpunkt das Jahr 2019 gesetzt und auch Monat und Tag stimmten nicht.

Probleme mit Garmin und Strava _01

Strava hat diese Dateien nun nicht akzeptiert da es praktisch eine Aktivität ist, die erst in der Zukunft stattfindet. Seltsamer Weise ist auf Garmin Connect alles i.O. Ignoriert Connect evtl. alle Datumsangaben außer der ersten (die ja korrekt war)? Ist es erst beim exportieren zu diesem Fehler gekommen? Eine korrekte Zeit sollte doch eigentlich vom GPS-Signal kommen. Ich hatte jedenfalls gehofft, dass Garmin und Strava etwas besser zusammenspielen. Direkt vom Handy zu Strava hatte ich jedenfalls (anteilsmäßig) weniger Probleme.

Ich habe anschließend direkt auf dem Garmin-Gerät geschaut. Dort hat die fit-Datei der entsprechenden Tour auch das Datum von 2019 – das Dateidatum ist allerdings korrekt. Damit scheint mir ausgeschlossen, dass beim Upload zu Garmin Connect oder beim Download der gpx etwas durcheinandergebracht wurde. Es ist wohl direkt bei der Aufzeichnung bzw auf dem Gerät passiert.

Probleme mit Garmin und Strava _02

Ich hatte das Problem zeitgleich an Garmin und Strava geschickt – von Garmin steht eine Antwort noch aus. Connect hat scheinbar keinen eigenen Support, ich hatte mich deshalb an den Geräte-Support gewandt. So flink wie bei Strava ist man aber offenbar nicht.

Die eigentlich erste Tour, die nicht funktionierte, habe ich dann selbst repariert. Die gpx-Datei in Notepad++ geöffnet, das falsche Datum (2019-09-28) gefunden, nach „2019-09-28“ suchen lassen und diesen Ausdruck automatisch durch das richtige Datum ersetzen lassen. Bei den ca. 3600 Trackpunkten der einstündigen Fahrt dauert das so nur einen Augenblick.

Das soeben geschilderte ist übrigens zwar das größte – aber leider nicht das einzige Problem mit meinem Garmin. Bei mir stellen sich gelegentlich die Einheiten für die Entfernung von Kilometer in Meilen bzw von Meter in Fuss um. Ich stelle es wieder richtig ein – und beim nächsten Mal oder irgendwann steht da wieder Meilen statt Kilometer. Das scheint ein Problem zu sein, das seit Jahren (immer wieder) auftritt – aber nicht bei jedem Gerät. Mögliche Lösungsansätze werden auf dieser Seite aufgelistet – ich bin noch nicht mit allen Punkten durch….

Was mir bei Garmin noch auffällt: die Geräte bzw. Software scheint recht empfindlich zu sein, was die USB-Kabel betrifft. Ich hatte – auch bei diversen Geräten im Familien- und Freundeskreis – das Problem, dass das jeweilige Gerät am PC nicht erkannt wurde. Bis mir irgendwann auffiel, dass das wohl immer geschah, wenn ich ein beliebiges Kabel verwendete. Laden kann ich die Geräte mit allen Kabeln, nur wenn man mittels Software auf das Gerät zugreifen will (für Updates oder zur Datensicherung) gab es Probleme. Nutze ich die Originalkabel, gibt es keine Schwierigkeiten. Das betrifft Edge, Dakota und diverses Auto-Navis.  Ich habe das nochmal mit verschiedenen Kabeln durchprobiert: von den diversen USB-Kabeln von anderen Geräten o.ä. die so rumliegen (ca. 7 Stück), funktioniert genau 1.  Bis ich das so bemerkte hat es eine Weile gedauert, in der ich Zeit mit der Fehlersuche verschwendete.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.